package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(-\s*)`)
var str = `To do list: - Buy milk - Feed cat`
var substitution = "\n$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}