re = /\s*(-\s*)/
str = 'To do list: - Buy milk - Feed cat'
subst = '\\n$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result