use strict;
my $str = 'To do list: - Buy milk - Feed cat';
my $regex = qr/\s*(-\s*)/p;
my $subst = '\\n$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";