$re = '/\s*(-\s*)/';
$str = 'To do list: - Buy milk - Feed cat';
$subst = "\n$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;