import Foundation
let pattern = #"\s*(-\s*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"To do list: - Buy milk - Feed cat"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)