#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)\{(.*)\}"
Local $sString = "someOtherMessage{" & @CRLF & _
" class = "someClass";" & @CRLF & _
" sampleMessage{" & @CRLF & _
" someValue{" & @CRLF & _
" someText{" & @CRLF & _
" someParam = "value";" & @CRLF & _
" someSymbol = "another_symbol";" & @CRLF & _
" }; //someText" & @CRLF & _
" }; //someValue" & @CRLF & _
" }; //sampleMessage" & @CRLF & _
" }; //someOtherMessage" & @CRLF & _
"" & @CRLF & _
"someOtherMessage2{" & @CRLF & _
" class = "someClass2";" & @CRLF & _
" sampleMessage2{" & @CRLF & _
" someValue2{" & @CRLF & _
" someText2{" & @CRLF & _
" someParam = "value2";" & @CRLF & _
" someSymbol = "another_symbol2";" & @CRLF & _
" }; //someText2" & @CRLF & _
" }; //someValue2" & @CRLF & _
" }; //sampleMessage2" & @CRLF & _
" }; //someOtherMessage2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")