const regex = new RegExp('(?s)\\{(.*)\\}', 'gm')
const str = `someOtherMessage{
class = "someClass";
sampleMessage{
someValue{
someText{
someParam = "value";
someSymbol = "another_symbol";
}; //someText
}; //someValue
}; //sampleMessage
}; //someOtherMessage
someOtherMessage2{
class = "someClass2";
sampleMessage2{
someValue2{
someText2{
someParam = "value2";
someSymbol = "another_symbol2";
}; //someText2
}; //someValue2
}; //sampleMessage2
}; //someOtherMessage2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}