import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\{(.*)\\}";
final String string = "someOtherMessage{\n"
+ " class = \"someClass\";\n"
+ " sampleMessage{\n"
+ " someValue{\n"
+ " someText{\n"
+ " someParam = \"value\";\n"
+ " someSymbol = \"another_symbol\";\n"
+ " }; //someText\n"
+ " }; //someValue\n"
+ " }; //sampleMessage\n"
+ " }; //someOtherMessage\n\n"
+ "someOtherMessage2{\n"
+ " class = \"someClass2\";\n"
+ " sampleMessage2{\n"
+ " someValue2{\n"
+ " someText2{\n"
+ " someParam = \"value2\";\n"
+ " someSymbol = \"another_symbol2\";\n"
+ " }; //someText2\n"
+ " }; //someValue2\n"
+ " }; //sampleMessage2\n"
+ " }; //someOtherMessage2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}