using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\{(.*)\}";
string input = @"someOtherMessage{
class = ""someClass"";
sampleMessage{
someValue{
someText{
someParam = ""value"";
someSymbol = ""another_symbol"";
}; //someText
}; //someValue
}; //sampleMessage
}; //someOtherMessage
someOtherMessage2{
class = ""someClass2"";
sampleMessage2{
someValue2{
someText2{
someParam = ""value2"";
someSymbol = ""another_symbol2"";
}; //someText2
}; //someValue2
}; //sampleMessage2
}; //someOtherMessage2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}