$re = '/(?s)\{(.*)\}/m';
$str = 'someOtherMessage{
class = "someClass";
sampleMessage{
someValue{
someText{
someParam = "value";
someSymbol = "another_symbol";
}; //someText
}; //someValue
}; //sampleMessage
}; //someOtherMessage
someOtherMessage2{
class = "someClass2";
sampleMessage2{
someValue2{
someText2{
someParam = "value2";
someSymbol = "another_symbol2";
}; //someText2
}; //someValue2
}; //sampleMessage2
}; //someOtherMessage2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);