package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\p{Zs}\p{P}]*?ह[^\p{Zs}\p{P}]*`)
var str = `तरह के लाभ मिलते हैं`
var substitution = "<b>$0</b>"
fmt.Println(re.ReplaceAllString(str, substitution))
}