use strict;
my $str = 'तरह के लाभ मिलते हैं';
my $regex = qr/[^\p{Zs}\p{P}]*?ह[^\p{Zs}\p{P}]*/up;
my $subst = '<b>$0</b>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";