const regex = /[^\p{Zs}\p{P}]*?ह[^\p{Zs}\p{P}]*/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\p{Zs}\\p{P}]*?ह[^\\p{Zs}\\p{P}]*', 'ug')
const str = `तरह के लाभ मिलते हैं`;
const subst = `<b>$0</b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);