// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)[^\p{Zs}\p{P}]*?ह[^\p{Zs}\p{P}]*").unwrap();
let string = "तरह के लाभ मिलते हैं";
let substitution = "<b>$0</b>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}