$re = '/[^\p{Zs}\p{P}]*?ह[^\p{Zs}\p{P}]*/u';
$str = 'तरह के लाभ मिलते हैं';
$subst = "<b>$0</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;