import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"[^\p{Zs}\p{P}]*?ह[^\p{Zs}\p{P}]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"तरह के लाभ मिलते हैं"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<b>$0</b>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)