import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!0)(?:9\\d\\d|\\d{4,5}|[1-7]\\d{5}|8[0-5]\\d{4}|86[0-3]\\d{3}|864000)$";
final String string = "0\n"
+ "10\n"
+ "899\n"
+ "900\n"
+ "1000\n"
+ "1001\n"
+ "99999\n"
+ "799999\n"
+ "800000\n"
+ "859999\n"
+ "860000\n"
+ "863999\n"
+ "864000\n"
+ "864001\n"
+ "999999\n"
+ "1000000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}