$re = '/^(?!0)(?:9\d\d|\d{4,5}|[1-7]\d{5}|8[0-5]\d{4}|86[0-3]\d{3}|864000)$/m';
$str = '0
10
899
900
1000
1001
99999
799999
800000
859999
860000
863999
864000
864001
999999
1000000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);