#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<String>(?::<Number>(?::<String>){0,2})? <Number>"
Local $sString = "<String>:<Number>:<String>:<String> <Number>" & @CRLF & _
"<String>:<Number>:<String> <Number>" & @CRLF & _
"<String>:<Number> <Number>" & @CRLF & _
"<String> <Number>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")