import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<String>(?::<Number>(?::<String>){0,2})? <Number>";
final String string = "<String>:<Number>:<String>:<String> <Number>\n"
+ "<String>:<Number>:<String> <Number>\n"
+ "<String>:<Number> <Number>\n"
+ "<String> <Number>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}