const regex = /<String>(?::<Number>(?::<String>){0,2})? <Number>/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<String>(?::<Number>(?::<String>){0,2})? <Number>', 'mg')
const str = `<String>:<Number>:<String>:<String> <Number>
<String>:<Number>:<String> <Number>
<String>:<Number> <Number>
<String> <Number>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}