$re = '/<String>(?::<Number>(?::<String>){0,2})? <Number>/m';
$str = '<String>:<Number>:<String>:<String> <Number>
<String>:<Number>:<String> <Number>
<String>:<Number> <Number>
<String> <Number>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);