using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<String>(?::<Number>(?::<String>){0,2})? <Number>";
string input = @"<String>:<Number>:<String>:<String> <Number>
<String>:<Number>:<String> <Number>
<String>:<Number> <Number>
<String> <Number>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}