package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<String>(?::<Number>(?::<String>){0,2})? <Number>`)
var str = `<String>:<Number>:<String>:<String> <Number>
<String>:<Number>:<String> <Number>
<String>:<Number> <Number>
<String> <Number>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}