const regex = /([#.A-Za-z0-9]+):({)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([#.A-Za-z0-9]+):({)', 'g')
const str = `#a:{width:100px;height:100px;background-color:black;} #b:{width:100px;}`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);