re = /([#.A-Za-z0-9]+):({)/
str = '#a:{width:100px;height:100px;background-color:black;} #b:{width:100px;}'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result