use strict;
my $str = '#a:{width:100px;height:100px;background-color:black;} #b:{width:100px;}';
my $regex = qr/([#.A-Za-z0-9]+):({)/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";