$re = '/([#.A-Za-z0-9]+):({)/';
$str = '#a:{width:100px;height:100px;background-color:black;} #b:{width:100px;}';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;