// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([#.A-Za-z0-9]+):({)").unwrap();
let string = "#a:{width:100px;height:100px;background-color:black;} #b:{width:100px;}";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}