import re
regex = re.compile(r"([#.A-Za-z0-9]+):({)")
test_str = "#a:{width:100px;height:100px;background-color:black;} #b:{width:100px;}"
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)