# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([$€£¥]\s{0,1}){0,1}((([0-9]{1,3}\s{0,1}){0,1}([0-9]{3}\s{0,1})*(,[0-9]{2}){0,1}))(\s{0,1}[$€£¥]){0,1}$//;t' <<< "€123 123 252,65
"