const regex = /^([$€£¥]\s{0,1}){0,1}((([0-9]{1,3}\s{0,1}){0,1}([0-9]{3}\s{0,1})*(,[0-9]{2}){0,1}))(\s{0,1}[$€£¥]){0,1}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([$€£¥]\\s{0,1}){0,1}((([0-9]{1,3}\\s{0,1}){0,1}([0-9]{3}\\s{0,1})*(,[0-9]{2}){0,1}))(\\s{0,1}[$€£¥]){0,1}$', '')
const str = `€123 123 252,65
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);