import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([$€£¥]\\s{0,1}){0,1}((([0-9]{1,3}\\s{0,1}){0,1}([0-9]{3}\\s{0,1})*(,[0-9]{2}){0,1}))(\\s{0,1}[$€£¥]){0,1}$";
final String string = "€123 123 252,65\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}