$re = '/^([$€£¥]\s{0,1}){0,1}((([0-9]{1,3}\s{0,1}){0,1}([0-9]{3}\s{0,1})*(,[0-9]{2}){0,1}))(\s{0,1}[$€£¥]){0,1}$/';
$str = '€123 123 252,65
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;