using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([$€£¥]\s{0,1}){0,1}((([0-9]{1,3}\s{0,1}){0,1}([0-9]{3}\s{0,1})*(,[0-9]{2}){0,1}))(\s{0,1}[$€£¥]){0,1}$";
string substitution = @"";
string input = @"€123 123 252,65
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}