package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([$€£¥]\s{0,1}){0,1}((([0-9]{1,3}\s{0,1}){0,1}([0-9]{3}\s{0,1})*(,[0-9]{2}){0,1}))(\s{0,1}[$€£¥]){0,1}$`)
var str = []byte(`€123 123 252,65
`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}