# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[ \t]*>+.*\n//gm;t' <<< " > Text...
>
> More random text.
foo bar
> More random text.
bar"