use strict;
my $str = ' > Text...
>
> More random text.
foo bar
> More random text.
bar';
my $regex = qr/[ \t]*>+.*\n/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";