re = /[ \t]*>+.*\n/m
str = ' > Text...
>
> More random text.
foo bar
> More random text.
bar'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result