#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[ \t]*>+.*\n"
Local $sString = " > Text..." & @CRLF & _
" >" & @CRLF & _
" > More random text. " & @CRLF & _
"foo bar" & @CRLF & _
" > More random text. " & @CRLF & _
"bar"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)