$re = '/[ \t]*>+.*\n/m';
$str = ' > Text...
>
> More random text.
foo bar
> More random text.
bar';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;