package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ \t]*>+.*\n`)
var str = ` > Text...
>
> More random text.
foo bar
> More random text.
bar`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}