using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<script.*?>.*?<\/script>)";
string input = @"<!DOCTYPE html>
<html lang=""en"">
<head>
<meta charset=""UTF-8"">
<title>Document</title>
</head>
<body>
<p>Lorem ipsum dolor sit amet, consectetur adipisicing elit. Nisi, modi.</p>
<script async type=""text/javascript"" src=""jquery-1.10.2.min.js""></script>
<script type=""text/javascript"" src=""effects.js"" async></script>
<script async>
void 0;
</script>
<!-- все скрипты , что выше не должны попасть в выборку -->
<script type=""text/javascript"" src=""prototype.js"" ></script>
<script type=""text/javascript"" src=""dragdrop.js""></script>
<script type=""text/javascript"" src=""controls.js""></script>
<script type=""text/javascript"" src=""slider.js""></script>
<script type=""text/javascript"">
void 0;
async_function();
</script>
</body>
</html>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}