import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<script.*?>.*?<\\/script>)";
final String string = "<!DOCTYPE html>\n"
+ "<html lang=\"en\">\n"
+ "<head>\n"
+ " <meta charset=\"UTF-8\">\n"
+ " <title>Document</title>\n"
+ "</head>\n"
+ "<body>\n"
+ " <p>Lorem ipsum dolor sit amet, consectetur adipisicing elit. Nisi, modi.</p>\n"
+ " <script async type=\"text/javascript\" src=\"jquery-1.10.2.min.js\"></script>\n"
+ " <script type=\"text/javascript\" src=\"effects.js\" async></script>\n"
+ " <script async>\n"
+ " void 0;\n"
+ " </script>\n"
+ " <!-- все скрипты , что выше не должны попасть в выборку -->\n"
+ " <script type=\"text/javascript\" src=\"prototype.js\" ></script>\n"
+ " <script type=\"text/javascript\" src=\"dragdrop.js\"></script>\n"
+ " <script type=\"text/javascript\" src=\"controls.js\"></script>\n"
+ " <script type=\"text/javascript\" src=\"slider.js\"></script>\n\n"
+ " <script type=\"text/javascript\">\n"
+ " void 0;\n"
+ " async_function();\n"
+ " </script>\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}