$re = '/(<script.*?>.*?<\/script>)/msi';
$str = '<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<title>Document</title>
</head>
<body>
<p>Lorem ipsum dolor sit amet, consectetur adipisicing elit. Nisi, modi.</p>
<script async type="text/javascript" src="jquery-1.10.2.min.js"></script>
<script type="text/javascript" src="effects.js" async></script>
<script async>
void 0;
</script>
<!-- все скрипты , что выше не должны попасть в выборку -->
<script type="text/javascript" src="prototype.js" ></script>
<script type="text/javascript" src="dragdrop.js"></script>
<script type="text/javascript" src="controls.js"></script>
<script type="text/javascript" src="slider.js"></script>
<script type="text/javascript">
void 0;
async_function();
</script>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);