const regex = /(<script.*?>.*?<\/script>)/msig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<script.*?>.*?<\\\/script>)', 'msig')
const str = `<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<title>Document</title>
</head>
<body>
<p>Lorem ipsum dolor sit amet, consectetur adipisicing elit. Nisi, modi.</p>
<script async type="text/javascript" src="jquery-1.10.2.min.js"></script>
<script type="text/javascript" src="effects.js" async></script>
<script async>
void 0;
</script>
<!-- все скрипты , что выше не должны попасть в выборку -->
<script type="text/javascript" src="prototype.js" ></script>
<script type="text/javascript" src="dragdrop.js"></script>
<script type="text/javascript" src="controls.js"></script>
<script type="text/javascript" src="slider.js"></script>
<script type="text/javascript">
void 0;
async_function();
</script>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}