# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<script.*?>.*?<\/script>)"
test_str = ("<!DOCTYPE html>\n"
"<html lang=\"en\">\n"
"<head>\n"
" <meta charset=\"UTF-8\">\n"
" <title>Document</title>\n"
"</head>\n"
"<body>\n"
" <p>Lorem ipsum dolor sit amet, consectetur adipisicing elit. Nisi, modi.</p>\n"
" <script async type=\"text/javascript\" src=\"jquery-1.10.2.min.js\"></script>\n"
" <script type=\"text/javascript\" src=\"effects.js\" async></script>\n"
" <script async>\n"
" void 0;\n"
" </script>\n"
" <!-- все скрипты , что выше не должны попасть в выборку -->\n"
" <script type=\"text/javascript\" src=\"prototype.js\" ></script>\n"
" <script type=\"text/javascript\" src=\"dragdrop.js\"></script>\n"
" <script type=\"text/javascript\" src=\"controls.js\"></script>\n"
" <script type=\"text/javascript\" src=\"slider.js\"></script>\n\n"
" <script type=\"text/javascript\">\n"
" void 0;\n"
" async_function();\n"
" </script>\n"
"</body>\n"
"</html>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.