#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sumi)^[A-Z\x{C0}-\x{2AF}'"\s-]+$"
Local $sString = "Fred" & @CRLF & _
"T3d" & @CRLF & _
"Björg" & @CRLF & _
"Shawn'iq'ua" & @CRLF & _
"Åbjørn" & @CRLF & _
"Mary-Jane" & @CRLF & _
"Æstrid" & @CRLF & _
"will.i.am"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")