import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z\\x{C0}-\\x{2AF}'\"\\s-]+$";
final String string = "Fred\n"
+ "T3d\n"
+ "Björg\n"
+ "Shawn'iq'ua\n"
+ "Åbjørn\n"
+ "Mary-Jane\n"
+ "Æstrid\n"
+ "will.i.am";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CASE | Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}