package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?smi)^[A-Z\x{C0}-\x{2AF}'"\s-]+$`)
var str = `Fred
T3d
Björg
Shawn'iq'ua
Åbjørn
Mary-Jane
Æstrid
will.i.am`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}